deploy application

Discussions about syncing data via Bluetooth, Dropbox, FTP, and using CSWeb
Post Reply
noel
Posts: 24
Joined: June 16th, 2012, 7:32 pm
Location: Libreville, Gabon

deploy application

Post by noel »

I try to deploy an application on a CSWeb server. I have an error message. Here is the content of the synclog file.

2022-09-28 18:53:49,754 INFO: Connection successful. Server id: b6e0f075-3a3c-4701-ab60-afc1fb8ff0fa
2022-09-28 18:53:49,757 INFO: Uploading package RGPH 5 TOGO - MODULE DE GESTION
2022-09-28 18:53:49,758 INFO: Uploading app package RGPH 5 TOGO - MODULE DE GESTION 349154 bytes
2022-09-28 18:53:50,256 ERROR: Invalid server response: JSON syntax_error at line 1 and column 1
2022-09-28 18:53:50,256 ERROR: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>

<title>405 - Le verbe HTTP utilis頰our acc餥r ࠣette page n'est pas autoris鮼/title>

<style type="text/css">

<!--

body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}

fieldset{padding:0 15px 10px 15px;}

h1{font-size:2.4em;margin:0;color:#FFF;}

h2{font-size:1.7em;margin:0;color:#CC0000;}

h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}

#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;

background-color:#555555;}

#content{margin:0 0 0 2%;position:relative;}

.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}

-->

</style>

</head>

<body>

<div id="header"><h1>Erreur de serveur</h1></div>

<div id="content">

<div class="content-container"><fieldset>

<h2>405 - Le verbe HTTP utilis頰our acc餥r ࠣette page n'est pas autoris鮼/h2>

<h3>La page que vous recherchez ne peut pas 괲e affich饬 car une m鴨ode incorrecte (verbe HTTP) a 鴩 utilis饠pour y acc餥r.</h3>

</fieldset></div>

</div>

</body>

</html>

I can upload the application in my own server but on the production server.

I need help for that.

It is a CSWeb 7.7.0 server.
aaronw
Posts: 531
Joined: June 9th, 2016, 9:38 am
Location: Washington, DC

Re: deploy application

Post by aaronw »

I'm translating the 405 error to "HTTP verb used to access this page is not allowed." When I do a google search for that phrase on stackoverflow.com I see a number of hits. I believe the issue is specific to a configuration on your production server and you'll need to walk through these search results to find your solution.
noel
Posts: 24
Joined: June 16th, 2012, 7:32 pm
Location: Libreville, Gabon

Re: deploy application

Post by noel »

Hi aaron,

Thank you for your help. As you said the problem was on the server. I worked with ITC team now and it worked.

Once again, thank you for your help.

Noël
SCardoso2022
Posts: 1
Joined: October 6th, 2022, 6:26 am

Re: deploy application

Post by SCardoso2022 »

How can I make showing my points on csweb using Map Report?
I have some datas, however it doesn't show anything.
sherrell
Posts: 314
Joined: April 2nd, 2014, 9:16 pm
Location: Washington, DC

Re: deploy application

Post by sherrell »

Since this is a new question, could you start a new thread in the Android folder? Also, explain what you mean by Map Report, and what exactly you are doing (provide a code fragment or your program). Thanks, Sherrell
Post Reply