Examples 7.5 folder and production runner

Other discussions about CSPro
Post Reply
shafique arif
Posts: 68
Joined: August 25th, 2013, 1:21 am

Examples 7.5 folder and production runner

Post by shafique arif » December 28th, 2020, 6:26 am

Dear Josh

For the last few CSPro versions, I always failed to get "Examples" subfolder in "Documents" folder. I checked with our IT person but he did not have any clue why examples folder failed to be copied to my machine. Can you please guide us in this regard. Also is there any other site from where I can copy this folder. I am using 7.5.1.

Also, when i run productionrunner, i get following message. any help will be appriciated.

Best
Attachments
error productionrunner.docx
(45.41 KiB) Downloaded 44 times

Gregory Martin
Posts: 1534
Joined: December 5th, 2011, 11:27 pm
Location: Washington, DC

Re: Examples 7.5 folder and production runner

Post by Gregory Martin » December 29th, 2020, 10:26 am

You can get the latest version of the Examples folder from here: https://github.com/CSProDevelopment/examples

Click on the "Code" button and then select "Download ZIP."

Regarding Production Runner, as that messages says, the tool will fail to open if you don't have the entire set of CSPro executables installed. Check your CSPro 7.5.1 installation folder (C:\Program Files (x86)\CSPro 7.5) ... do you see 171 files and 2 folders there? If not, then something is going wrong with the installation.

Another possibility is that at some point you modified Production Runner's settings to specify that you wanted to use a specific version of CSPro that is no longer installed on your computer. If so, you will have to go into your registry editor to remove that setting:

1) Click Windows Key + R (run), and type "regedit"
2) In the search bar, paste "HKEY_CURRENT_USER\SOFTWARE\U.S. Census Bureau\Tools\Production Runner"
3) If that key exists, delete the "Version" value.

shafique arif
Posts: 68
Joined: August 25th, 2013, 1:21 am

Re: Examples 7.5 folder and production runner

Post by shafique arif » December 29th, 2020, 11:35 am

Thanks a lot a lot Gregory. I deleted "version" (which was 7.2) and it is working now.
Wish you, your team and all the CSProUsers a very happy, safe and prosperous 2021.
Best

Post Reply