android 5.5 synconnect

Discussions about creating CAPI applications to run on Android devices
Post Reply
AriSilva
Posts: 512
Joined: July 22nd, 2016, 3:55 pm

android 5.5 synconnect

Post by AriSilva » October 2nd, 2021, 6:04 pm

Hi folks,
The application connects well with the server if I use a tablet working with Android 11, but the same app, cannot connect with the server if I use my old tablets with android 5.5.
I´ve tried to reinstall 7.6.2 in the tablet but it does not seem to be able to get data from the server, please see the attached message.
Best
Ari
Attachments
unable to connect.png
unable to connect.png (53.19 KiB) Viewed 2484 times
Best
Ari

savy
Posts: 87
Joined: December 27th, 2012, 1:36 pm

Re: android 5.5 synconnect

Post by savy » October 5th, 2021, 1:27 pm

Are you using LetsEncrypt for SSL? There seems to be a known issue for SSL trust on older Android versions. Please check this post
https://community.letsencrypt.org/t/cer ... oid/120061

AriSilva
Posts: 512
Joined: July 22nd, 2016, 3:55 pm

Re: android 5.5 synconnect

Post by AriSilva » October 16th, 2021, 6:01 am

Thanks for the tip, I tried to look at that post, but it seems to be written in greek to me, or other language that I´m unable to decipher.
Is this SSL problem in the server? How can we change that? We did not change anything in the server, and all the other applications work fine using cspro 7.5 (I had to reinstall 7.5 and change the dictionaries to 7.5 in order to solve this problem)
Best
Ari

AriSilva
Posts: 512
Joined: July 22nd, 2016, 3:55 pm

Re: android 5.5 synconnect

Post by AriSilva » October 19th, 2021, 10:14 am

Thanks for the info, I´ve done some testing, and the problem is located at the https:, where it works in the new android 11, but it does not in the old androids 5.5, so I changed to http and it is working now.
I´m not sure if it has anything to do with the changes to the 7.6 version.
Thanks again
Ari
Best
Ari

Post Reply