Problemas Csentry 7.6.2 y android 11

Discussions about creating CAPI applications to run on Android devices
Post Reply
jodapecol
Posts: 8
Joined: August 25th, 2017, 9:56 am

Problemas Csentry 7.6.2 y android 11

Post by jodapecol » August 1st, 2021, 10:39 am

Good Cspro Team.
We are using Csentry 7.6.2 with android 11 (samsung), and the option to call third-party applications is not working
using: "ExecSystem" or "SystemApp Object".

What we are implementing is calling the maps.me application from our Csentry application.

Due to this inconvenience during the past week we began to test the Csentry 7.6.2 in all versions of android in the office android 4.4, 5, 6, 7.1.1, 7.1.2, 8, 9 and 10; everything works very well.

And we realize that the problem is only occurring with version 11 of android.
Any suggestions to fix, or does it have something to do with android 11 security restrictions.

We need help to solve this problem.
From already thank you very much.
Pd: Excuse me, I use the google translator to write to you in English.

Gregory Martin
Posts: 1534
Joined: December 5th, 2011, 11:27 pm
Location: Washington, DC

Re: Problemas Csentry 7.6.2 y android 11

Post by Gregory Martin » August 3rd, 2021, 7:36 am

Thanks for reporting this problem. This indeed is an issue due to a change that Google made for Android 11. You can read about it here:

https://medium.com/androiddevelopers/pa ... 857f221cd9

We fixed the issue, at least temporarily, and updated the version of CSEntry in Google Play yesterday. If you get the update and SystemApp still does not work, please let us know.

karina
Posts: 1
Joined: September 20th, 2021, 4:58 am

Re: Problemas Csentry 7.6.2 y android 11

Post by karina » September 20th, 2021, 5:17 am

Hello CsPro Team,

May I also inquire about a similar problem we encountered with the use of cs entry in android 11 tablets? We developed an enumerator's application that creates a pff file for our csentry CAPI app. Creating these files inside the CSentry folder worked just fine with android 10 and lower version. But with android 11, this is no longer possible. Our application can no longer read files inside cs entry folder as well. We tried the solution you provided for this issue but it's not working for us.

Is there a way we can get around this issue? Is there a folder to which our app could create a file to, and to which csentry app could also read from?

Thank you in advance for your help.

Best,
Karen

Post Reply