CSEntry crash

Discussions about creating CAPI applications to run on Android devices
Post Reply
Posts: 8
Joined: November 26th, 2018, 11:46 pm

CSEntry crash

Post by gdupuis » June 4th, 2021, 6:21 am


I am working on converting an Android system we have developed from 7.3 to 7.6 (though we successfully converted a country-specific system to 7.5 already). In testing on Android, I am running into an issue where it seems the system is unable to write a new record. Below are the things I have tried out and other information:

- Initially, it seemed very similar to this post on crashing - https://www.csprousers.org/forum/viewto ... =10&t=3376 - I also was seeing it after using setvalueset(). However, upon moving variables around on the form or removing the setvalueset() call, it's clear that it's not related to a specific variable or even specific code. Upon entering the record (which correlates to a section of our questionnaire), it briefly pauses on the first question (about 1 second) and then crashes.
- I attempted putting in error messages throughout as seemed to work in the above post (perhaps to slow down the system so things could catch up), but no success.
- I am able to enter data perfectly fine on Windows. In fact, if I start a record on Windows, partially save and exit out, and then copy the folder onto an Android, I am able to navigate to the record in the Android and everything runs smoothly, and I can continue entering more data for the record (i.e. add on to what I entered in my Windows laptop). This is what makes me think it's crashing at the point of trying to write a new record line to the data file.
- Other records earlier in the questionnaire that have identical code and identical set up function fine (literally, the difference is the word "rice" or "mango" in crashing sections instead of "maize" in a functioning section).
- It seems that sections of the questionnaire corresponding to the records function fine until we get to about halfway through our questionnaire. Then all subsequent sections crash.
- This is replicated across at least three different Android tablets (I have two different kinds of Samsungs, my colleague has a third).
- I am not sure if the size of the program could be a factor - it's really a very large questionnaire, and since it's our core, we have many many modules and this is the first time testing all at once in one giant program. Previously, we've cut the program by nearly half for implementation, so I'm not sure if the size is a factor potentially.
- I did send crash reports through the app, one including a quick description, if it's useful.

I think that covers all the information I have. I am wondering if there is a memory issue? Or if something didn't convert quite right when moving my system to 7.6? Thanks to anyone with ideas!

Attached is the program itself, as well as an Android installation for replication of the issue. To replicate, drop the folder into the csentry folder, then use the Interviewer.pff to open the menu. Select option 1. Data entry options; choose HH number 1; choose option 2. Revisit incomplete household (if that doesn't work, option 3 will); a screen for AHVRESULT should appear - advance to end; choose select module for data entry; select "OPEN - Module 7.52 Sheep". It should jump to a screen to select the respondent briefly and then crashes.

Thank you :)
Genevieve Dupuis (ICF)
CMID application.zip
CMID application
(420.51 KiB) Downloaded 32 times
CMID android.zip
CMID android folder
(573.76 KiB) Downloaded 29 times

Posts: 8
Joined: November 26th, 2018, 11:46 pm

Re: CSEntry crash

Post by gdupuis » June 4th, 2021, 6:24 am

I forgot to mention that I also tried deleting the forms where the data are collected that were being crashed and recreating them from scratch, but no luck there either!

Posts: 85
Joined: December 27th, 2012, 1:36 pm

Re: CSEntry crash

Post by savy » June 8th, 2021, 2:04 pm

We are able to reproduce your problem. The case tree on Android is causing a crash. We have a workaround for you. In CSPro designer, set the option for "Show case tree:" to Never. Regenerate the .pen file and run your application. At runtime, once the application comes up, you can use the menu option in Android to show the case tree again. We will have a fix for you in the next version.

Posts: 8
Joined: November 26th, 2018, 11:46 pm

Re: CSEntry crash

Post by gdupuis » June 9th, 2021, 1:41 pm

Wonderful! In that you were able to reproduce the problem and have a workaround for us. That is super and we hugely appreciate your help. We will hide the case tree (which is very fine for use) and adjust add a note to our training materials about displaying the case tree if necessary.

Thank you!

Gregory Martin
Posts: 1534
Joined: December 5th, 2011, 11:27 pm
Location: Washington, DC

Re: CSEntry crash

Post by Gregory Martin » July 7th, 2021, 1:36 pm

This is fixed in 7.6.2, which was put online today. If automatic updates are enabled, you will get the latest version from Google Play shortly.

Post Reply