Wrong sync data to web server

Discussions about CSEntry
Komin
Posts: 60
Joined: July 23rd, 2016, 1:27 pm

Wrong sync data to web server

Post by Komin » May 25th, 2018, 12:54 am

Dear CSPro team,

First, I have 3 variables (Q1, Q2 & Q3) with 5 cases that i sync into CSWeb server with message reveal successfully but i was added 2 variables (Q4 & Q5) with data punching 3 cases totally 8 cases.

Second, I deleted the old dictionary in CSWeb server that storage 2 cases than I added dictionary start with 0 cases again to web server with pnc and pff to server again.

Third, I start sync data again but it is show only 3 cases in CSWeb server.

My question, how about the old 5 cases why did not sync to CSWeb server? What's wrong is it? Could please advice me?

Best regards,
Komin
Last edited by Komin on May 25th, 2018, 3:27 am, edited 1 time in total.

josh
Posts: 1916
Joined: May 5th, 2014, 12:49 pm
Location: Washington DC

Re: Wrong sync data to web server

Post by josh » May 25th, 2018, 3:26 am

Look in the sync.log file on the device you ran the sync from. It will show you how many cases it uploaded each time you ran the sync. That should offer some clues as to what is going on. Normally when you sync only new cases are sent but when you delete the dictionary on the server it should realize that the server has no cases and send everything again. If for some reason that check is failing it will be clear from the sync.log file.

Komin
Posts: 60
Joined: July 23rd, 2016, 1:27 pm

Re: Wrong sync data to web server

Post by Komin » May 25th, 2018, 5:25 am

It still the same problem.

Komin

josh
Posts: 1916
Joined: May 5th, 2014, 12:49 pm
Location: Washington DC

Re: Wrong sync data to web server

Post by josh » May 26th, 2018, 1:37 pm

What did the sync.log say?

Komin
Posts: 60
Joined: July 23rd, 2016, 1:27 pm

Re: Wrong sync data to web server

Post by Komin » May 27th, 2018, 9:20 am

Dear CSPro team,

I didn't see log file in CSWeb server, it is show "This directory is empty".

Regards,
Komin

josh
Posts: 1916
Joined: May 5th, 2014, 12:49 pm
Location: Washington DC

Re: Wrong sync data to web server

Post by josh » May 28th, 2018, 12:01 pm

As I said in my earlier response "Look in the sync.log file on the device you ran the sync from". The file can be found in the CSEntry directory on Android and in C:\users\<your username>\C:\Users\josh\AppData\Roaming\CSPro on Windows desktop.

Komin
Posts: 60
Joined: July 23rd, 2016, 1:27 pm

Re: Wrong sync data to web server

Post by Komin » May 29th, 2018, 5:19 am

Dear CSPro tea,

Please find attached log file with advise what's wrong is it?

Komin
Last edited by Komin on June 9th, 2018, 12:03 am, edited 1 time in total.

josh
Posts: 1916
Joined: May 5th, 2014, 12:49 pm
Location: Washington DC

Re: Wrong sync data to web server

Post by josh » May 29th, 2018, 6:43 am

29/05/2018 16:09:56.000 INFO: Last PUT with this server 2018-05-27 20:17:53 local rev 37 server rev "125"
29/05/2018 16:09:56.000 INFO: Total new/modified cases since last sync: 0
Looks it is not uploading the cases since they have not changed since the last sync. Try opening the cases in CSEntry, modifying them, saving them and sync again.

Komin
Posts: 60
Joined: July 23rd, 2016, 1:27 pm

Re: Wrong sync data to web server

Post by Komin » May 29th, 2018, 8:45 am

Dear CSPRo team,

Thanks for your help & now i can solved this problem based on your replay.
Do i need to modify all cases?

I notice that CSWeb 7.0 is working very well on data sync especially when i deleted the old dictionary and upload a new dictionary to web server it is sync all case to CSWeb without modified all cases like CSWeb 7.1. This is my observation on CSWeb 7.0 VS 7.1.

Best regards,
Komin

josh
Posts: 1916
Joined: May 5th, 2014, 12:49 pm
Location: Washington DC

Re: Wrong sync data to web server

Post by josh » May 29th, 2018, 5:59 pm

You are correct. This does seem to be a bug in CSPro 7.1. We are looking into it.

Post Reply